Discussion:
Where to submit bugs for adplus.exe?
(too old to reply)
kodehoved
2010-08-17 07:06:03 UTC
Permalink
Raw Message
Some time ago I submitted a bug report for the new version of adplus on the
VS Connect site. However, it was closed as adplus.exe is not part of VS. I
can't find a suitable Connect site for Debugging Tools, so I don't know how
to pass this information to the appropriate parties.

The Connect entry is here:
https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=576341&wa=wsignin1.0
pat styles [microsoft]
2010-08-17 13:50:47 UTC
Permalink
Raw Message
Posting to this newsgroup is a good way to get someone to look at it. I
will pass it on.

.pat styles [microsoft]

"kodehoved" wrote in message
news:1CCDBC1A-47AE-44B0-AFF3-***@microsoft.com...

Some time ago I submitted a bug report for the new version of adplus on the
VS Connect site. However, it was closed as adplus.exe is not part of VS. I
can't find a suitable Connect site for Debugging Tools, so I don't know how
to pass this information to the appropriate parties.

The Connect entry is here:
https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=576341&wa=wsignin1.0
pat styles [microsoft]
2010-08-18 00:49:25 UTC
Permalink
Raw Message
Hello.

I passed this on to the developer and he was unable to reproduce your
problem. Here is what he said...

---------------------------------------------

I can't repro this problem. The customer says that the issue is because cdb
can't be found but I think this isn't the case. I believe what can't be
found is the application that he wants to spawn.

Ask the customer to try it with calc.exe, like:

adplus -crash -o c:\dumps -sc calc.exe

This works perfectly fine for me and I don't have the debuggers folder in my
path.

---------------------------------------------

"kodehoved" wrote in message
news:1CCDBC1A-47AE-44B0-AFF3-***@microsoft.com...

Some time ago I submitted a bug report for the new version of adplus on the
VS Connect site. However, it was closed as adplus.exe is not part of VS. I
can't find a suitable Connect site for Debugging Tools, so I don't know how
to pass this information to the appropriate parties.

The Connect entry is here:
https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=576341&wa=wsignin1.0
w***@bluerockresearch.com
2011-09-21 18:26:22 UTC
Permalink
Raw Message
The following does not generate a crash dump and my EXE is never launched:

C:\temp> adplus -crash -sc DebugException.exe

In contrast, this launches my EXE and generates a crash dump:

C:\temp> adplus -crash -sc c:\temp\DebugException.exe


Actually, both work on my Windows 7 machine (ADPlus Engine Version: 7.01.002 02/27/2009). Only the second works on my Windows XP machine. (ADPlus Version: 6.03.006 12/16/2008).

Here is some of ADPlus_report.txt on my XP box when I do not include the full path:

ADPlus Version: 6.03.006
ADPlus Version Date: 12/16/2008
OS Version: 5.1
OS Build: 2600
Debuggers Installation Directory: C:\Program Files\Debugging Tools for Windows (x86)
Command line arguments used were:
-crash -sc DebugException.exe
Script engine Version: 5.7.16599
Selected debugger: cdb.exe
Output Directory: C:\Program Files\Debugging Tools for Windows (x86)\Crash_Mode__Date_09-21-2011__Time_14-15-44PM
Starting to attach the debugger to each process
Spawning: DebugException.exe

On Tuesday, August 17, 2010 8:49:25 PM UTC-4, pat styles [microsoft] wrote:
> Hello.
>
> I passed this on to the developer and he was unable to reproduce your
> problem. Here is what he said...
>
> ---------------------------------------------
>
> I can't repro this problem. The customer says that the issue is because cdb
> can't be found but I think this isn't the case. I believe what can't be
> found is the application that he wants to spawn.
>
> Ask the customer to try it with calc.exe, like:
>
> adplus -crash -o c:\dumps -sc calc.exe
>
> This works perfectly fine for me and I don't have the debuggers folder in my
> path.
>
> ---------------------------------------------
>
> "kodehoved" wrote in message
> news:1CCDBC1A-47AE-44B0-AFF3-***@microsoft.com...
>
> Some time ago I submitted a bug report for the new version of adplus on the
> VS Connect site. However, it was closed as adplus.exe is not part of VS. I
> can't find a suitable Connect site for Debugging Tools, so I don't know how
> to pass this information to the appropriate parties.
>
> The Connect entry is here:
> https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=576341&wa=wsignin1.0
Loading...