Discussion:
problem analyzing mindump from win7 upgrade
(too old to reply)
b***@gmail.com
2014-02-04 23:32:56 UTC
Permalink
Raw Message
Hello,
My task is to upgrade a windows vista machine to a windows 7 machine, but the process keeps crashing with a vague error. On the internet I found that it is a good idea to take the crash dump, look at it in windbg, and search for driver issues.

I have windbg installed on a second computer.
I have my symbol path set to: SRV*C:\SymCache*http://msdl.microsoft.com/download/symbols

I am running windbg as administrator.

When I open the crash dump, I get the following:

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\RuppelBJ\Desktop\setupmem.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows 7 Kernel Version 7600 MP (4 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16385.x86fre.win7_rtm.090713-1255
Machine Name:
Kernel base = 0x82613000 PsLoadedModuleList = 0x8275b810
Debug session time: Thu Jan 30 17:14:20.368 2014 (UTC - 5:00)
System Uptime: 0 days 0:01:44.131
Loading Kernel Symbols
...............................................................
................................................................
.....................................
Loading User Symbols
Loading unloaded module list
...................

and it hangs there.

When I use !sym noisy and .reload /f, I get a lot of messages like the following:


I get a bunch of

SYMSRV: c:\symcache\secdrv.SYS\45080528a000\secdrv.SYS not found
SYMSRV: http://msdl.microsoft.com/download/symbols/secdrv.SYS/45080528a000/secdrv.SYS not found
DBGHELP: C:\Program Files\Debugging Tools for Windows (x64)\secdrv.SYS - file not found
SYMSRV: C:\SymCache\secdrv.SYS\45080528a000\secdrv.SYS not found
SYMSRV: http://msdl.microsoft.com/download/symbols/secdrv.SYS/45080528a000/secdrv.SYS not found
DBGENG: \SystemRoot\System32\Drivers\secdrv.SYS - Image mapping disallowed by non-local path.
Unable to load image \SystemRoot\System32\Drivers\secdrv.SYS, Win32 error 0n2
DBGENG: secdrv.SYS - Partial symbol image load missing image info
DBGHELP: No header for secdrv.SYS. Searching for dbg file
DBGHELP: .\secdrv.dbg - file not found
DBGHELP: .\SYS\secdrv.dbg - path not found
DBGHELP: .\symbols\SYS\secdrv.dbg - path not found
DBGHELP: secdrv.SYS missing debug info. Searching for pdb anyway
DBGHELP: Can't use symbol server for secdrv.pdb - no header information available
DBGHELP: secdrv.pdb - file not found
*** WARNING: Unable to verify timestamp for secdrv.SYS
*** ERROR: Module load completed but symbols could not be loaded for secdrv.SYS
DBGHELP: secdrv - no symbols loaded

SYMSRV: USBD.SYS from http://msdl.microsoft.com/download/symbols: 3019 bytes - copied
DBGHELP: c:\symcache\USBD.SYS\4A5BC8691700\USBD.SYS - OK
DBGENG: c:\symcache\USBD.SYS\4A5BC8691700\USBD.SYS - Mapped image memory
SYMSRV: usbd.pdb from http://msdl.microsoft.com/download/symbols: 2687 bytes - copied
DBGHELP: USBD - public symbols
c:\symcache\usbd.pdb\AB29F7729DAE48E594E83E606EF9F4061\usbd.pdb


but when that's all said and done, windbg seems to hang on
Loading User Symbols
Loading unloaded module list
...................

and there is no cpu or network usage.

Any suggestions?

Thanks!
r***@gmail.com
2014-03-08 18:23:13 UTC
Permalink
Raw Message
I think your symbols are downloading from symbol server. let this download complete..

may be you can use symchk command

http://msdn.microsoft.com/en-us/library/windows/hardware/ff560157(v=vs.85).aspx

Hope this helps..

Let me know, if this was the issue.

Loading...